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Introduction and Overview
This document provides instructions on how to use the new and improved Exam Editor to
create exams for Learning Tree courses. The Exam Editor is available for download from
pdev.learningtree.com and requires Java 1.6 or later. If you get an error message after
you try to launch the Exam Editor, download the latest version of Java from:
http://java.com/en/download/index.jsp
If you are connected to the Internet when you launch the Exam Editor on subsequent
occasions, it will check to see if a new version has been released and will update your
version, if necessary.
The Exam Editor will place an icon on your desktop. On PCs, you can also find it after it
has been installed by going to Start | All Programs | Learning Tree | Learning Tree Exam
Editor.
The Exam Editor has been revised so that authors now only need to create 60 unique
questions from which three 40-question exams can be created. (Previously, authors were
asked to provide 80 unique questions for two exams or 120 questions for three exams.)
The 60 questions are broken down into three groups of 20 (Groups 1, 2 and 3). Two of the
three groups are combined to make one exam. For example:
Group 1 + Group 2 = Exam A
Group 2 + Group 3 = Exam B
Group 1 + Group 3 = Exam C
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Creating New Exams from Scratch – New Courses
Step 1: Because the Exam Editor calculates how many questions you need from each
chapter, it’s important that you have the most-current PowerPoint files for each chapter on
your computer. Make sure that you don’t use the Exam Editor until your PowerPoint files
are completed so you get accurate slide counts.
Step 2: Start the Exam Editor. The opening screen looks like this:

Step 3: Click on File/New Exam or click on this icon:

Enter the course number and title in the fields of the New Exam Information box that has
appeared:

Click OK.
Step 4: You will then be prompted to give the new exam a file name:

The naming convention is xxx-Exam-yy.xml, where xxx is the course number (419), and yy
is the revision number (a1). Click on Save.
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The Exam Editor main screen will open. You will notice that the default answer for each
question is A, and the Chapters and Groups are all in red.

Step 5: Click on Question/Question Calculator or on its icon:

This will open the “Specify Chapter Slide Counts” window. Click on the Open icon in the
top left corner:

Navigate to your course’s PowerPoint folder with the current revision files and select the
folder itself or any chapter file. Assuming the files are in the same folder, all of the chapters
will be located by the Exam Editor and will appear in the slide count table:

Step 6: The Question Calculator is now showing us how many slides are in each chapter
(e.g., 28 slides in Chapter 1, 67 slides in Chapter 2). The Question Calculator uses this
information to calculate a target for how many questions you should write from each
chapter. You don’t want to include Chapter 0 or the Course Summary chapter. In this
example, the Course Summary chapter is Chapter 10, so we will uncheck the Include box
for that chapter and click OK:
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If you accidentally uncheck the wrong box, you may always manually add chapters back in
by clicking on the new icon (see below) in the “Specify Chapter Slide Counts” window:

Slide counts can also be manually edited, if needed.

Step 7: Now that the Exam Editor knows how many slides are in each chapter, it can give
us a target number of questions that should be written from each chapter for each group.
The target exam numbers are found in the lower right corner of the Exam Editor’s main
screen:

To find more detailed information, click on Tools/Display Validation Data or click this
Question Validation Information icon:
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Step 8: The following box will then appear:

This tells us that there are currently lines for 60 questions in the Exam Editor, although
none of them have been written at this point. It also gives us our target exam numbers.
Based on this, we should try to have three questions for each of the three groups from
Chapter 1 (total of nine questions), two questions for each of the three groups for Chapter
2 (total of six questions), etc.
In this example, the number of questions from each chapter for each group totals 21.
Sometimes that number will be exactly 20. Remember that these are targets, and you
may be off by plus or minus one question.
The Question Validation Information box also gives us a target for how many of the correct
answers in each group should be A, B, C and D. In the example above, we should strive to
make A the correct answer five times in each of the three groups of 20 questions.
The other thing to note is that all of the boxes are in red. This tells us that we haven’t hit
our goals. Boxes will turn green when the goals are met.
Step 9: The next step is to write your exam questions. To edit a question or assign it to a
group or chapter, double click on the question. The question and answers will expand.
Assign the question to a Group and Chapter at the top of the page and select the correct
answer on the right side. You may move answers up and down using the arrows to the left
of each answer. Click OK when you are done with the question and move on to the next.
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When a Group and Chapter have been assigned, they boxes will change from red, and the
Groups are color coded:

You may also sort the questions by Chapter or Group by clicking on the top of the Chap or
Grp columns. A little up arrow will appear. If you click at the top of the column again, the
arrow will turn downward, the sorting will be reversed. You may clear any sorting by
clicking on Question/Clear sorting.

As long as you have sorting turned off, you may also manually drag and move questions
around. You may not, however, determine the order that attendees will see the
questions on the exams. The questions are randomized by the Exam Editor for the
actual exams.
Step 10: Continue on through all of the questions, assigning Groups and Chapters. To
delete a question, make sure your cursor is on that question and select Question/Delete
Question(s), or click on the trash can icon:

You may also delete a question when you are in edit mode by clicking on the trash can or
selecting Edit/Delete question.
Tip: At any time, you may click on the Question Validation Information icon or select
Tools/Display Validation Data to see how you are doing toward your goals. In the screen
shot below, the boxes in green show that the goals are met. The red boxes indicate that
the goals have not been met.
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Step 11: Continue until you have 60 questions and all green boxes in the Question
Validation Information box.

Note that when all of the boxes are green, the Question Validation Information icon will
also turn green:

Step 12: Make sure you have saved the new exam and send the resulting XML file to
Publications. You’re done!
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Editing Exams
Note: This section discusses how to use the Exam Editor for revisions. Please remember
that adding/removing content during a revision may affect the question distribution in
exams.

Step 1: Make sure that you have the most-current PowerPoint files for your course (the
final ones for the revision) on your computer. The safest way is to request them from
Publications.
Step 2: Request that Publications sends you the XML file that contains your current 60
exam questions. Save that file onto your computer.
Step 3: Start the Exam Editor.
Step 4: Click on File/Open Exam. Navigate to the XML file you received from Publications
and select it. Click on Open. All of your current exam questions will be imported into the
Exam Editor. Before you do any work on the exam, click on File/Save As and change the
revision level in the exam name.
Step 5: You will now see all of the questions from your current exam in the Exam Editor.

“Grp” represents the three groups of 20 questions previously created. “Chap” indicates
from which chapter in the course you pulled the question.
Step 6: Click on Question/Question Calculator or on its icon:

This will open the “Specify Chapter Slide Counts” window. Click on the Open icon in the
top left corner:
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Navigate to your course’s PowerPoint folder and select the folder itself or any chapter file.
Assuming the files are in the same folder, all of the chapters will be located by the Exam
Editor and will appear in the slide count table.
Step 7: The Question Calculator is now showing us how many slides are in each chapter.
The Question Calculator uses this information to calculate a target for how many questions
you should write from each chapter. You don’t want to include Chapter 0 or the Course
Summary chapter. If the Course Summary chapter has been included, uncheck the
Include box for that chapter and click OK.
If you accidentally uncheck the wrong box, you may always manually add chapters back in
by clicking on the new icon (see below) in the “Specify Chapter Slide Counts” window:

Slide counts can also be manually edited, if needed.

Step 8: Now that the Exam Editor knows how many slides are in each chapter, it can give
us a target number of questions that should be written from each chapter for each group.
The target exam numbers are found in the lower right corner of the Exam Editor’s main
screen:

To find more detailed information, click on Tools/Display Validation Data or click this
Question Validation Information icon:

Step 9: The following box will then appear:
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This tells us that there are currently 60 questions in the Exam Editor. It also gives us our
target exam numbers. Based on this, we should try to have three questions for each of the
three groups from Chapter 1 (total of nine questions), three questions for each of the three
groups for Chapter 2 (total of nine questions), etc.
In this example, the number of questions from each chapter for each group totals 21.
Sometimes that number will be exactly 20. Remember that these are targets, and you
may be off by plus or minus one question.
The Question Validation Information box also gives us a target for how many of the correct
answers in each group should be A, B, C and D. In the example above, we should strive to
make A the correct answer five times in each of the three groups of 20 questions.
The other thing to note is that some of the boxes are in red. This tells us that we haven’t
hit our goals. Boxes will turn green when the goals are met.
Step 10: The next step is to review the questions and determine if any questions, or their
assigned Chapters or Groups need to be changed based on the revision.
To edit a question or assign it to a group or chapter, double click on the question. The
question and answers will expand. Assign the question to a Group and Chapter at the top
of the page and select the correct answer on the right side. You may move the answers
up and down using the arrows to the left of each answer. Click OK when you are done with
the question and move on to the next.

To delete a question, make sure your cursor is on that question and select
Question/Delete Question(s), or click on the trash can icon:

You may also delete a question when you are in edit mode by clicking on the trash can or
selecting Edit/Delete question.
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Tip: At any time, you may click on the Question Validation Information icon or select
Tools/Display Validation Data to see how you are doing toward your goals. In the screen
shot below, the boxes in green show that the goals are met. The red boxes indicate that
the goals have not been met.
Step 11: Continue until you are happy with all 60 questions and the boxes are all green in
the Question Validation Information box.

Note that when all of the boxes are green, the Question Validation Information icon will
also turn green:

As long as you have sorting turned off, you may also manually drag and move questions
around. You may not, however, determine the order that attendees will see the
questions on the exams. The questions are randomized by the Exam Editor for the
actual exams.
Step 13: Make sure you have saved the new exam and send the resulting XML file to
Publications. They will handle everything from here. You’re done!
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Adding an Image
From time to time, you might want an image to appear as part of a question or answer. To
add an image click on this icon on the right side of the question/answer:

The following dialog box will appear:

If you click on “Provide a description,” a dialog box will appear where you may type in
instructions for Publications to create an image. The gray circle to the right of the question
will turn yellow, and the “delete image” icon will no longer be grayed out:

If you click on “Select an image,” the following will appear, allowing you to choose an
image on your computer:

When you insert an image, you won’t see it in the Exam Editor until you go to File | Print
Preview. You will also notice that the grey circle to the right of the question has turned
blue, and the “delete image” icon is no longer grayed out:

Please submit the image source file(s) to Publications when you return the exam XML file.
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Main Screen Menu and Toolbar Options
The previous sections have attempted to explain step by step how to use the Exam Editor.
This section provides a brief overview of what each of the menu and toolbar options does
on the main screen of the Exam Editor.
The File Menu

New Exam – Click on this to create a new exam from scratch.
Open Exam – Click on this to open an existing exam.
Close Exam – Click on this to close an exam.
Save – Click on this to save an exam with its current name.
Save As – Click on this to save an exam with a new name.
Print Preview – Click on this to see a preview of the 60 questions in PDF format. The
questions are in exam format, along with the Chapter, Group and correct answer letter for
each question outlined in a red.

Login to Database – Used by Publications only
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Load from Database - Used by Publications to load questions into the Exam Editor from
the database. An individual exam (A,B,C) can be loaded or all current questions for a
course.
Publish to Database – Used by Publications to publish an exam from the Exam Editor
into the database
Batch Publish to Database – Used by Publications to publish an entire folder of exam
XML files to the database
Properties – When you click on this, the box below appears. You may edit the course
number, title, exam letter, exam revision, exam revision date, exam prior revision and
copyright year. This is mostly used by Publications.

Exit – Click on this to exit the Exam Editor.

The Question Menu

Question Calculator – Click on this to open a new box that will tell the Exam Editor which
chapters it should consider when it calculates the target number of questions per chapter.
Insert New Question Before – Click on this to insert a new question before whatever
question you have highlighted in the Exam Editor.
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Insert New Question After – Click on this to insert a new question after whatever
question you have highlighted in the Exam Editor.
Import Questions – Click on this to import questions from other exams into the exam on
which you are working.
Edit Question – Click on this to open up the question you have highlighted in the Exam
Editor so you may edit it.
Delete Question(s) – Click on this to delete the question(s) you have highlighted in the
Exam Editor.
Move Question Up – Click on this to move the question you have highlighted in the Exam
Editor up one position.
Move Question Down – Click on this to move the question you have highlighted in the
Exam Editor down one position.
The Tools Menu

Find (Search) in Questions – Click on this to search for a particular word in the questions
and/or answers. There is also a toolbar icon for this function. See below.
Type in the word you want to locate:

If the word is found in a question, that will be indicated in the “Find” column next to the
question with an pair of binoculars in front of a pink background. If you hover your mouse
over this, you will see “Search string found in the question intro.”

If the word is found in an answer, that will be indicated in the “Find” column next to the
question with an pair of binoculars in front of a purple (or “radiant orchid,” the Pantone
Color of the Year 2014) background. If you hover your mouse over this, you will see
“Search string found in one or more question answers.”
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If the word is found in a both the question and one or more answers, that will be indicated
in the “Find” column next to the question with an pair of binoculars in front of a coral
background. If you hover your mouse over this, you will see “Search string found in the
question intro and also in one or more question answers.”

Check Spelling in Questions – Click on this to check the spelling in all questions. There
is also a toolbar icon for this function. See below.
Display Validation Data – Click on this to see your target number of questions per
Chapter and Group along with how many A, B, C and D answers you should have.
Open Decode XML Tool – This is for internal use. Course authors do not use this.
The Help Menu

About – Click on this to see the version of the Exam Editor and to find an email address to
which you can address comments.
Help Topics – Click on this to go to the Product Development Web site:
pdev.learningtree.com. Click on Exam Editor to get to this User Guide.

Toolbar Icons
All of the items on the toolbar also have corresponding menu items. The icons are for your
convenience. They all display tool tips when you hover on them with your mouse.
Create new Save
exam
exam

Open existing Print
exam
preview

Question Insert
Calculator question
below

Insert
question
above

Delete
selected
question

Search

Edit
Import
question questions
from
another
exam

Question
validation
information

Spell
check

January 15, 2014

ExamEditor/UG/A.4/401/A.3

18

Question Editor Menu and Toolbar Options
This section provides a brief overview of what each of the menu and toolbar options does
on the Question Editor screen of the Exam Editor, which is where each individual question
is written and edited.

The File Menu

Cancel – Click on this to escape from the current question without saving any changes.
The Edit Menu

Undo – Click on this to undo the last edit.
Redo – Click on this to redo the last edit.
Cut – After selecting text, click on this to cut it.
Copy – After selecting text, click on this to copy it.
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Paste – After selecting a location, click on this to paste the selected text with its original
formatting intact.
Paste Unformatted Text - After selecting a location, click on this to paste the selected text
without any formatting. Use this when copying and pasting from external sources, such as
Microsoft Word.
Delete Question – Use this to delete the current question.
Select All – When your cursor is in a field, click on this to select everything in that field.
Edit previous question – When you click on this, you are taken to the previous question.
Edit next question – When you click on this, you are taken to the next question.
The Insert Menu

Fill-In-The-Blank-Line – When you click on this, a blank line of eight spaces is entered.
Example:

Do not use a blank line to end a question; in this case, omit the blank line and use a colon.
Do not use a blank line to begin a question; instead, reword the question so that the blank
line falls somewhere in the middle.
Indent – When you click on this, the text is indented where you have your cursor.
EN Dash – When you click on this, an EN dash is inserted. Example:

EM Dash – When you click on this, an EM dash is inserted. Example:

Left Double Curly Quote – When you click this, the following is inserted:
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Right Double Curly Quote – When you click this, the following is inserted:
Left Single Curly Quote – When you click this, the following is inserted:
Right Single Curly Quote – When you click this, the following is inserted:
Right Arrow – When you click on this, the following is inserted:
The Format Menu

Italic – When you click on this, any selected text is italicized.
Underline – When you click on this, any selected text is underlined.
Superscript – When you click on this, any selected text is raised and made smaller.
Subscript – When you click on this, any selected text is lowered and made smaller.
Century Schoolbook – When you click on this, any selected text is put in the Century
Schoolbook typeface. Apply this plus italics to the word “not” when asking for a choice that
is incorrect or unlike the other responses, or to any other word that is to be emphasized in
a question stem.
Example: Which statement is not true?
Apply Century Schoolbook plus italics to terms that the question asks the attendee to
define.
Example: In object-oriented terms, a class is:
Courier New (fixed width code font) – When you click on this, any selected text is put in
the Courier New typeface. This is used when questions or answers contain
programming code or file names.
For guidelines on exam styles, please see the Product Development website at
pdev.learningtree.com and click on:
Publications Style Guide and Writing Manual
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The Tools Menu

Check Spelling – Click on this to check the spelling for the question and answers on
which you are currently working.
Toolbar Icons
All of the items on the toolbar also have corresponding menu items. The icons are for your
convenience. They all display tool tips when you hover on them with your mouse.
Paste
Cut to
formatted
clipboard text

Indent
Century
Delete
Redo last
four
Underline Subscript Schoolbook spaces
question edit

Paste
Copy to
clipboard unformatted
text

Undo last
edit
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Fill-in-the- EN dash
blank line

Save changes
and edit
previous
question

Spell Save changes
check and edit next
question

